Blog do Project - Tudo que você queria saber sobre Microsoft Project

Criação Cubo OLAP Project Server 2013

Após terminar a instalação do Project Server 2013, podemos criar um Cubo Padrão.

A conta que criará o cubo deverá ter permissões específicas no banco de dados criado pelo Project Server 2013. No meu caso utilizei a conta admin.

Acesse o SQL Server, selecione a conta Admin, ao abrir as propriedades da conta, selecione User Mapping e marque o banco de dados que foi criado para o EPM 2013, o padrão é o ProjectWebApp e em Database Role Membership marque a opção de PSDataAccess.

image

O próximo passo é acessar a Administração Central, Manage Service Applications – Aplicativo do Project criado e depois em Manage no PWA que foi provisionado.

 

image

image

image

Clique em OLAP Database Name para informar o nome do servidor e nome do cubo a ser criado.

image

Clique em Configuration para selecionar os campos que deverão ser inseridos no cubo

image

image

Após salvar, clique em BUILD NOW, assim que iniciar o processo clique no Status para abrir uma nova página com o processamento do cubo.

image

Se aparecer a mensagem de erro como esta abaixo, é porque faltou instalar o AMO do SQL Server 2008 R2, mesmo que voce esteje utilizando o SQL Server 2012 o AMO do SQL Server 2008 R2 deve ser instalado.

image

No blog do Brian Smith, existe o link para baixar as Features Pack do SQL Server

http://blogs.msdn.com/b/brismith/archive/2012/11/12/project-server-2013-requirements-to-build-an-olap-cube.aspx

e também possui o link direto para baixar apenas o AMO.

http://download.microsoft.com/download/F/7/B/F7B7A246-6B35-40E9-8509-72D2F8D63B80/SQLSERVER2008_ASAMO10_amd64.msi

Após instalar no servidor, faça novamente um novo Build e verifique o status da criação do cubo.

image

 

Abraços

Diego Pereira

Erro Event Viewer 1108 – SQL Server Reporting Services cannot load the SQLPDW extension.

Um erro comum de acontecer em ambientes SharePoint 2010 ou 2013 com SQL Server 2012 e SSRS (Reporting Services) com modo integrado:

“SQL Server Reporting Services Shared Service cannot load the SQLPDW extension. (Application: [service app name]. CorrelationId: etc.)”

ou

“SQL Server Reporting Services Shared Service cannot load the TERADATA extension. (Application: [service app name]. CorrelationId: etc.)”

Este erro ocorre porque a extensão TERADATA é registrada no arquivo de configuração do Reporting Services por padrão, mas o assemblies não.

image

Se você não esta utilizando o TERADATA ou SQLPDW provavelmente vai querer que seu event viewer não fique indicando erros.

Assim, utilize o comando PowerShell abaixo:

$ssrs = Get-SPRSServiceApplication

write-host “Removing Teradata : Data”
Remove-SPRSExtension -Name “TERADATA” -ExtensionType “Data” -Identity $ssrs.Id

write-host “Removing Teradata : ModelGeneration”
Remove-SPRSExtension -Name “TERADATA” -ExtensionType “ModelGeneration” -Identity $ssrs.Id

write-host “Removing Teradata : SemanticQuery”
Remove-SPRSExtension -Name “TERADATA” -ExtensionType “SemanticQuery” -Identity $ssrs.Id

write-host “Removing SQLPDW : Data”
Remove-SPRSExtension -Name “SQLPDW” -ExtensionType “Data” -Identity $ssrs.Id

write-host “Removing SQLPDW: SemanticQuery”
Remove-SPRSExtension -Name “SQLPDW” -ExtensionType “SemanticQuery” -Identity $ssrs.Id

Abraços

Diego Pereira

Erro ao aplicar Service Pack 1 SharePoint 2013

Pessoal, ao aplicar a correção do Service Pack 1 do SharePoint 2013 e Language Pack em um ambiente de produção onde possuo 1 maquina de Aplicação e 1 máquina Web Front-End e tentar rodar o wizard de qualquer uma das máquinas, sempre era exibido um erro dizendo que estava faltando aplicar o SP1. Se tentava aplicar novamente o SP1 não era possível porque já estava aplicado.

image

 

Todos os servidores foram reiniciados e mesmo assim o problema continuava.

Para resolver e fazer com que o SharePoint entenda que as atualizações já estão aplicadas, rode o comando abaixo no PowerShell

Get-SPProduct –local

image

Este comando irá forçar uma atualização no servidor. Será preciso executar o comando em todas as maquinas onde ocorrem o erro e depois basta rodar o wizard que ele será executado normalmente.

Abraços
Diego Pereira